Capa » Artigos » Pilhas em VisualG

Pilhas em VisualG

Saudações a todos.

Todos os estudantes de tecnologia sempre se deparam com pilhas, pensando nisso, temos no Purainfo pilhas em C++, Pilhas com String em C++. Agora, graças ao programador Salvador da Pátria Jefferson costa, temos uma Pilha com “Locadora de Livros” em Visualg.

algoritmo "locadora de livros"

var
topo, n, aux, posicao : inteiro
vet : vetor [1..3] de caracter
y, opcao : caracter
k: inteiro
data: caracter
nome: caracter

inicio

n <- 3
topo <- 0

repita

limpatela

escreval ("Nossa locadora de livros")
escreval (" ")
escreval (" ")

para k de n ate 1 passo -1 faca
  escreval (k, " ... " , vet[k])
fimpara

escreval ("incluir ... 1")
escreval ("Topo...... ", topo)
escreval (" ")
escreval ("---------------------------------------------")
escreval (" ")
escreval (" ")

escreval( "Menu Operacoes")
escreval( "0 - Sair")
escreval( "1 - ALUGAR")
escreva ("Escolha uma opcao ... ")
leia(opcao)

se opcao = "1" entao
   escreva( "Informe o nome do livro ... ")
   leia(y)
   escreval ( "Informe o nome do cliente ... ")
   leia(nome)
   escreval ( "Data do emprestimo ... ")
   leia(data)

escreval( " " )
se topo = n entao
    escreval ("Overflow - Inclusao Nao Executada - pressione enter")
    leia(y)
    senao
    topo <- topo + 1
    vet[topo] <-y + nome + data
fimse
fimse

ate opcao="0"
fim algoritmo

É isso aí. Até a próxima, e sinta-se a vontade para postar mais, Jefferson.

Sobre Diego Duarte

Diego Duarte Atua como Analista NOC, Bacharel em Sistemas de Informação MCP, MCDST, MCSA, MCTS, Também Violo tocão nas horas vagas!

3 comentários

  1. eexcelente sugestão coloca a opção excluir

  2. marcos alexandre silva

    gostaria de saber qual é o código para exclusão na pilha

  3. gostaria de saber qual é o código para exclusão na pilha

Este artigo lhe foi útil? comente e ajude outros acrescentando seu ponto de vista!